Будь умным!


У вас вопросы?
У нас ответы:) SamZan.ru

Лабораторная работа 5 Имитационное моделирование методом МонтеКарло Выполнила студентка гру

Работа добавлена на сайт samzan.ru: 2016-03-13

РОССИЙСКИЙ ГОСУДАРСТВЕННЫЙ СОЦИАЛЬНЫЙ УНИВЕРСИТЕТ

Факультет социального страхования, экономики и социологии труда

Лабораторная работа № 5 «Имитационное моделирование методом Монте-Карло»

Выполнила студентка группы

ЭКН-Д-1(М)

Голубева Екатерина Юрьевна

МОСКВА

2012


Лабораторная работа № 5 «Excel»

Задание:

Изучить тему: Метод Монте-Карло как разновидность имитационного моделирования

Выполнение работы:

С помощью метода Монте-Карло мы можем прогнозировать.

Непосредственно в нашей задаче, нам дано количество продаж автомобилей за 5 дней.

кол-во продаж

кол-во дней

0

10

1

20

2

70

3

60

4

30

5

10

Нам нужно рассчитать, сколько в среднем будут продавать машин каждый день в последующие 10 дней.

Для этого мы рассчитаем таблицу:

кол-во продаж

кол-во дней

вероятность

кумулят. вероятность

интервал случ. чисел

0

10

0,05

0,05

0

5

1

20

0,1

0,15

6

15

2

70

0,35

0,5

16

50

3

60

0,3

0,8

51

80

4

30

0,15

0,95

81

95

5

10

0,05

1

96

100

Рассмотрим, как мы получили каждый компонент:

Вероятность = количество дней/ на сумму количества дней

Кумулятивная вероятность = это накопленная вероятность, то есть:

кумулят. вероятность

0,05

0,05+0,1=0,15

0,15+0,35=0,5

0,5+0,3=0,8

0,8+0,15=0,95

0,95+0,05=1

Интервал случайных чисел:

Верхняя граница = кумулятивная вероятность*100

Нижняя граница равна:

интервал случ. чисел

0

5

5+1=6

15

15+1=16

50

50+1=51

80

80+1=81

95

95+1=96

100

Для дальнейших вычислений рассчитаем таблицу:

№ дня

случайное число

количество продаж

№ дня: 1-10.

Случайное число рассчитывается с помощью встроенной функции Excel СЛЧИС, эта функция выдает нам случайные числа в диапазоне от нуля до единицы. Поэтому для наших вычислений умножим ее на 100.

=СЛЧИС()*100

Количество продаж будем рассчитывать с помощью функций ЕСЛИ.

Итак 1 день:

=ЕСЛИ(B12<=$F$3;$A$3;ЕСЛИ(B12<=$F$4;$A$4;ЕСЛИ(B12<=$F$5;$A$5;ЕСЛИ(B12<=$F$6;$A$6;ЕСЛИ(B12<=$F$7;$A$7;ЕСЛИ(B12<=$F$8;$A$8;0))))))

2 день:

=ЕСЛИ(B13<=$F$3;$A$3;ЕСЛИ(B13<=$F$4;$A$4;ЕСЛИ(B13<=$F$5;$A$5;ЕСЛИ(B13<=$F$6;$A$6;ЕСЛИ(B13<=$F$7;$A$7;ЕСЛИ(B13<=$F$8;$A$8;0))))))

И так далее меняя только значение ячейки В, в которой заложены случайные числа.

=СРЗНАЧ(C12:C21)

Такую итерацию мы повторяем 100 раз.

Затем считаем общее среднее значение, равное сумме всех средних значений по строке 22.

общее среднее

2,54

Вывод: в среднем в последующие 10 дней будут покупать по 2,5 автомобиля (2-3 автомобиля).


1. 01 Оборожный ЮА Правила создания пользовательского интерфейса Интерфейс пользователя он же
2. Архитектура Италии 15 века
3. Проблема добра и зла в романе М Булгакова Мастер и Маргарита
4. 1выплата з-п рабкам- Дт 70 Кт 50 основание ~ расчетноплатежная ведомость платежная ведомость; 2передача нали
5. геополитика а Челлен б Хаусхофер в Маккиндер гВ
6. Тема- Прокурорский надзор за исполнением законов в государственном управлении Ре
7. Источники конституционного права России
8. Александр Александрович Ведерников
9. Тема 3 Правильность экономической речи
10. Создание двухколончатого и трехколончатого текста на странице Для изменения количества колонок на стр.html
11. Улица Времени с элементами театрализации
12. Расчет производственного цикла
13. Тема Экономика и организация производство Фамилия студента Мусатов
14. Изучение конструкции и проверка работоспособности ротаметра
15. тема норм регулирующих такие трудовые отношения образует самостоятельную отрасль международного частного
16. тематики и кибернетики Кафедра высшей математики и математического моделирования КУРСОВА
17. гигиенических норм по содержанию в атмосфере городов окислов углерода азота пыли токсичных соединений мет
18.  События в Югославии в начале 90х годов развивались стремительно во многом непредсказуемо и трагично
19. ПЕРВОУРАЛЬСКИЙ МЕТАЛЛУРГИЧЕСКИЙ КОЛЛЕДЖ СОГЛАСОВАНО Протокол методич
20. стр. Защитим своё жилище от огня в условиях зимних холодов