Будь умным!


У вас вопросы?
У нас ответы:) SamZan.ru

Лабораторная работа 5 Имитационное моделирование методом МонтеКарло Выполнила студентка гру

Работа добавлена на сайт samzan.ru: 2016-03-13

РОССИЙСКИЙ ГОСУДАРСТВЕННЫЙ СОЦИАЛЬНЫЙ УНИВЕРСИТЕТ

Факультет социального страхования, экономики и социологии труда

Лабораторная работа № 5 «Имитационное моделирование методом Монте-Карло»

Выполнила студентка группы

ЭКН-Д-1(М)

Голубева Екатерина Юрьевна

МОСКВА

2012


Лабораторная работа № 5 «Excel»

Задание:

Изучить тему: Метод Монте-Карло как разновидность имитационного моделирования

Выполнение работы:

С помощью метода Монте-Карло мы можем прогнозировать.

Непосредственно в нашей задаче, нам дано количество продаж автомобилей за 5 дней.

кол-во продаж

кол-во дней

0

10

1

20

2

70

3

60

4

30

5

10

Нам нужно рассчитать, сколько в среднем будут продавать машин каждый день в последующие 10 дней.

Для этого мы рассчитаем таблицу:

кол-во продаж

кол-во дней

вероятность

кумулят. вероятность

интервал случ. чисел

0

10

0,05

0,05

0

5

1

20

0,1

0,15

6

15

2

70

0,35

0,5

16

50

3

60

0,3

0,8

51

80

4

30

0,15

0,95

81

95

5

10

0,05

1

96

100

Рассмотрим, как мы получили каждый компонент:

Вероятность = количество дней/ на сумму количества дней

Кумулятивная вероятность = это накопленная вероятность, то есть:

кумулят. вероятность

0,05

0,05+0,1=0,15

0,15+0,35=0,5

0,5+0,3=0,8

0,8+0,15=0,95

0,95+0,05=1

Интервал случайных чисел:

Верхняя граница = кумулятивная вероятность*100

Нижняя граница равна:

интервал случ. чисел

0

5

5+1=6

15

15+1=16

50

50+1=51

80

80+1=81

95

95+1=96

100

Для дальнейших вычислений рассчитаем таблицу:

№ дня

случайное число

количество продаж

№ дня: 1-10.

Случайное число рассчитывается с помощью встроенной функции Excel СЛЧИС, эта функция выдает нам случайные числа в диапазоне от нуля до единицы. Поэтому для наших вычислений умножим ее на 100.

=СЛЧИС()*100

Количество продаж будем рассчитывать с помощью функций ЕСЛИ.

Итак 1 день:

=ЕСЛИ(B12<=$F$3;$A$3;ЕСЛИ(B12<=$F$4;$A$4;ЕСЛИ(B12<=$F$5;$A$5;ЕСЛИ(B12<=$F$6;$A$6;ЕСЛИ(B12<=$F$7;$A$7;ЕСЛИ(B12<=$F$8;$A$8;0))))))

2 день:

=ЕСЛИ(B13<=$F$3;$A$3;ЕСЛИ(B13<=$F$4;$A$4;ЕСЛИ(B13<=$F$5;$A$5;ЕСЛИ(B13<=$F$6;$A$6;ЕСЛИ(B13<=$F$7;$A$7;ЕСЛИ(B13<=$F$8;$A$8;0))))))

И так далее меняя только значение ячейки В, в которой заложены случайные числа.

=СРЗНАЧ(C12:C21)

Такую итерацию мы повторяем 100 раз.

Затем считаем общее среднее значение, равное сумме всех средних значений по строке 22.

общее среднее

2,54

Вывод: в среднем в последующие 10 дней будут покупать по 2,5 автомобиля (2-3 автомобиля).


1. Мэтлок Подписано в печать 06
2. Проект промышленной сортировочной станции и технология ее работы
3. 1 Понятие сущность и содержание права собственности на землю
4. вариант Типового закона принят на 27 сессии ЮНСИТРАЛ в 1994 г
5. 3 Введение
6. Клетки человеческой природы
7. аналоговая форма сигнала записана в виде последовательности коротких дискретных значений амплитуд звуко
8.  Азизова Рания
9. Он ехал проселочной дорогой
10. Что ты имеешь в виду
11. воспитательном процессе в школе.
12. М- Мысль 1995 590 [1] с
13. МОСКОВСКИЙ АВТОМОБИЛЬНОДОРОЖНЫЙ ГОСУДАРСТВЕННЫЙ ТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ МАДИ ф
14. Реферат- Всемирный Потоп и смещение полюсов
15. Аналоговые электронные вольтметры
16. Англия во время правления Георга V
17. тема приспосабливает свои ресурсы к динамическим условиям внешней и внутренней среды
18. Тема- Етика ~ вчення про мораль План Етика ~ вчення про мораль
19. Основные сырьевые материалы для производства газобетонных блоков из ячеистого бетона
20. Тематичні зустрічі та події які відвідав 3