Будь умным!


У вас вопросы?
У нас ответы:) SamZan.ru

Лабораторная работа 5 Имитационное моделирование методом МонтеКарло Выполнила студентка гру

Работа добавлена на сайт samzan.ru: 2016-03-13

РОССИЙСКИЙ ГОСУДАРСТВЕННЫЙ СОЦИАЛЬНЫЙ УНИВЕРСИТЕТ

Факультет социального страхования, экономики и социологии труда

Лабораторная работа № 5 «Имитационное моделирование методом Монте-Карло»

Выполнила студентка группы

ЭКН-Д-1(М)

Голубева Екатерина Юрьевна

МОСКВА

2012


Лабораторная работа № 5 «Excel»

Задание:

Изучить тему: Метод Монте-Карло как разновидность имитационного моделирования

Выполнение работы:

С помощью метода Монте-Карло мы можем прогнозировать.

Непосредственно в нашей задаче, нам дано количество продаж автомобилей за 5 дней.

кол-во продаж

кол-во дней

0

10

1

20

2

70

3

60

4

30

5

10

Нам нужно рассчитать, сколько в среднем будут продавать машин каждый день в последующие 10 дней.

Для этого мы рассчитаем таблицу:

кол-во продаж

кол-во дней

вероятность

кумулят. вероятность

интервал случ. чисел

0

10

0,05

0,05

0

5

1

20

0,1

0,15

6

15

2

70

0,35

0,5

16

50

3

60

0,3

0,8

51

80

4

30

0,15

0,95

81

95

5

10

0,05

1

96

100

Рассмотрим, как мы получили каждый компонент:

Вероятность = количество дней/ на сумму количества дней

Кумулятивная вероятность = это накопленная вероятность, то есть:

кумулят. вероятность

0,05

0,05+0,1=0,15

0,15+0,35=0,5

0,5+0,3=0,8

0,8+0,15=0,95

0,95+0,05=1

Интервал случайных чисел:

Верхняя граница = кумулятивная вероятность*100

Нижняя граница равна:

интервал случ. чисел

0

5

5+1=6

15

15+1=16

50

50+1=51

80

80+1=81

95

95+1=96

100

Для дальнейших вычислений рассчитаем таблицу:

№ дня

случайное число

количество продаж

№ дня: 1-10.

Случайное число рассчитывается с помощью встроенной функции Excel СЛЧИС, эта функция выдает нам случайные числа в диапазоне от нуля до единицы. Поэтому для наших вычислений умножим ее на 100.

=СЛЧИС()*100

Количество продаж будем рассчитывать с помощью функций ЕСЛИ.

Итак 1 день:

=ЕСЛИ(B12<=$F$3;$A$3;ЕСЛИ(B12<=$F$4;$A$4;ЕСЛИ(B12<=$F$5;$A$5;ЕСЛИ(B12<=$F$6;$A$6;ЕСЛИ(B12<=$F$7;$A$7;ЕСЛИ(B12<=$F$8;$A$8;0))))))

2 день:

=ЕСЛИ(B13<=$F$3;$A$3;ЕСЛИ(B13<=$F$4;$A$4;ЕСЛИ(B13<=$F$5;$A$5;ЕСЛИ(B13<=$F$6;$A$6;ЕСЛИ(B13<=$F$7;$A$7;ЕСЛИ(B13<=$F$8;$A$8;0))))))

И так далее меняя только значение ячейки В, в которой заложены случайные числа.

=СРЗНАЧ(C12:C21)

Такую итерацию мы повторяем 100 раз.

Затем считаем общее среднее значение, равное сумме всех средних значений по строке 22.

общее среднее

2,54

Вывод: в среднем в последующие 10 дней будут покупать по 2,5 автомобиля (2-3 автомобиля).


1. Пароутворення з відкритої поверхні рідини називається випаровуванням
2.  ПОНЯТИЕ ОСОБЕННОЙ ЧАСТИ УГОЛОВНОГО ЗАКОНОДАТЕЛЬСТВА
3. Оценка стоимости объекта недвижимости
4. Сны о Японии. Заявка и работа должны быть предоставлены организаторам не позднее 1 июля
5. Длительность жизненного цикла не одинакова у разных товаров
6. Реферат- Физика и богословие
7. смысловые типы речи- повествование описание рассуждение Под типом речи понимают следующие ее виды-
8. тема зажигания стартер приборы освещения и сигнализации контрольноизмерительные приборы все переч
9. Список использованной литературы Зарождение и формирование русск
10. принадлежность факторов ресурсов и результатов производства субъектам
11. 43 Структура и методы научного познания Раскрытие структуры научного знания его форм и методов
12. Союз справедливих
13. 65 020400 ~ Психология СанктПетербург 2011 ББК 88
14. цену реформ в стране; от нее во многом зависят степень социальной напряженности характер и направленность
15. Тема- Міри довжини
16.  Выявление и расследование преступлений ~ особое направление правоохранительной деятельности должностных
17. Тематична контрольна робота 3 зі світової літератури уч 11 класу .
18. ТЕМА 8 ГОСУДАРСТВЕННЫЕ СЛУЖАЩИЕ
19. Предмет и объекты бухгалтерского учета
20. Технология принятия управленческих решений