Будь умным!


У вас вопросы?
У нас ответы:) SamZan.ru

схемы Примечание знаком обозначена операция присваивания

Работа добавлена на сайт samzan.ru: 2016-03-13


ГИА 9 класс

В9.  Умение исполнить простейший циклический алгоритм, записанный на алгоритмическом языке.

Задачи

  1.  Определите значение переменной с после выполнения фрагмента алгоритма, записанного в виде блок-схемы:

Примечание: знаком := обозначена операция присваивания. В ответе укажите одно число — значение переменной с.

  1.  Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на двух языках программирования.

Паскаль

Алгоритмический язык

var s, i: integer;

begin

s:=0;

for i:=2 to 10 do

s:=s+i;

write (s);

end.

алг

нач

цел s, i

s:=0

нц для i от 2 до 10

  s:=s+i

кц

вывод s

кон

  1.  Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на двух языках программирования.

Паскаль

Алгоритмический язык

var s, k: integer;

begin

s:=50;

for  k:=0 to 8 do

s:=s – 4;

write (s);

end.

алг

нач

цел s, k

s:=50

нц для k от 0 до 8

  s:=s - 4

кц 

вывод s

кон

  1.  Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на двух языках программирования.

Паскаль

Алгоритмический язык

var a, b: integer;

begin

a:=2;

b:=0;

while a<>10 do

begin

  a:=a+2;

  b:=b+3*a;

end;

write (b);

end.

алг

нач

цел a, b

a:=2

b:=0

нц пока  a<> 10

  a:=a+2

  b:=b+3*a

кц 

вывод b

кон




1. ТЕМА 6 ВАЛЮТНИЙ РИНОК І ВАЛЮТНІ СИСТЕМИ СУТНІСТЬ ВАЛЮТИ І ВАЛЮТНОГО КУРСУ
2. РЕФЕРАТ дисертації на здобуття наукового ступеня кандидата історичних наук Ужгород ~ 2
3. Борьба русских земель и княжеств с монгольским завоеванием и крестоносцами в ХIII в
4. На тему Внутренние морские воды Курс ~ III Группа38 Выполнил Хомицкий Андрей
5. модуль Методы бизнестренинга- октябрь 2013 г
6. ТЕМА Рабство как исторически возникшая и наиболее грубая форма эксплуатации при которой раб наряду с ору
7. тема стадий российского уголовного процесса
8. Овердрафт
9.  Основные условия хранения и подготовки к перевозке СПГ Основная задача хранения и перевозки скоропортящи
10. Шварц Е
11. Екзистенціалізм К Ясперса- проблема трансцендентного
12. тематическое и целенаправленное порождение и усвоение нововведений включая реализацию достижений научнот
13. Положение о составе затрат по производству и реализации продукции работ услуг включаемых в себестоимост
14. Художественное изображение обездоленных людей в пьесе м. Горького на дн
15. тема КлиентБанк
16. Экология пищевых продуктов
17.  Исходные данные недели Объемы производства тыс
18. этим живет большинство людей
19. Понятие методологии психологии
20. Токарно-винторезный станок