Будь умным!


У вас вопросы?
У нас ответы:) SamZan.ru

Лекция 15 Подготовка к лабораторным работам Проверка гипотез о характере распределения

Работа добавлена на сайт samzan.ru: 2015-07-10

Лекция 15.  Подготовка к лабораторным работам

          Проверка гипотез о характере распределения.

                              Критерий   - квадрат.                                      

Цель работы:  Создать таблицу для вычисления расчетных частот попадания наблюдений в заданные интервалы в предположении, что наблюдаемая величина имеет НОРМАЛЬНОЕ  распределение с параметрами   = <x>,  = S, где  <x> - выборочное среднее, S – среднеквадратическое отклонение, вычисленные в предыдущей таблице. В этой же таблице вычисляются частоты и в предположении    РАВНОМЕРНОГО распределения на отрезке [A;B]. В качестве оценок параметров A и B берём начало первого и конец последнего интервала.

Исходные данные:  Таблица расчёта выборочных характеристик по интервальному  ряду (Лабораторная работа №  1)

Результат:  1. Электронная таблица для расчёта нормальных частот и наблюдаемого значения критерия согласия Пирсона (“-квадрат”) для гипотезы о нормальном распределении.

                       2.  Совместный график наблюдаемых и расчётных частот.

Расчёт  частот и наблюдаемого значения критерия 2

Расчетная частота попадания нормальной величины в интервал  (A;B)  равна

        Kn =  N * [ Ф(( B -  )/) - Ф(( A -  )/)]                   

Здесь  N -  полное число наблюдений;  Ф – функция Лапласа или интегральная функция нормального распределения в EXCEL это функция   НОРМСТРАСП( )

Для равномерного распределения равные частоты вычисляются по формуле:

                Ku =  N * H / ( BA )  ,

где в качестве границ распределения  A и B выбираем начало  первого и конец последнего интервала.

Критерий согласия между расчётными частотами K и наблюдаемыми частотами M  вычисляется как нормированная  сумма квадратов отклонений

                           2набл   =    (Mj-Kj)2/Kj                                    

Критическая точка  2кр вычисляется по распределению Пирсона с  L-3  степенями свободы  ( L – число интервалов) для заданного уровня значимости      (вероятности ошибки) как корень уравнения      H(x,L-3) =   ,  где  H – интегральная функция распределения Пирсона  или как

                                 2кр   =   H~(, L-3) ,

где  H~   - функция обратного распределения. В EXСEL это  функция  ХИ2ОБР( ; )

 

Если    2набл  > 2кр     гипотеза  о  нормальном    распределении   

                                          ОТВЕРГАЕТСЯ  

Руководство к составлению таблицы.

Таблица № 2 является продолжением таблицы № 1. В ней используются величины, вычисленные ранее, в Таблице №1.

  1.  Откроем  в EXCEL  файл с таблицей № 1  из 1-й лабораторной работы.
  2.  Выделим (“закрасим”) ВСЮ таблицу и скопируем её в буфер. (Команда “Копировать” из меню “Правка” или соответствующая иконка-пиктограмма в верхней линейке).
  3.  Откроем (создадим) новый файл. ( Команда  “Создать” в меню “Файл”) и  вставим  в него из буфера  скопированную таблицу (Команда “Вставить” из меню “Правка”).

Создадим таблицу № 2

4. В клетке   A20 вводим заголовок  “ПРОВЕРКА ГИПОТЕЗ О ХАРАКТЕРЕ РАСПРЕДЕЛЕНИЯ”

5.  В клетки  H20, I20 и J20 поместим заголовки  “L”, “A” и “B”  для числа интервалов  и границ равномерного распределения

  1.  В клетки  I21 и J21 введём формулы для вычисления этих границ:                      

                                   I                    J

                      21   =H2         =H2+H20*I2

    В клетку H21  будем вводить число заполненных интервалов.

  1.  В строке 22 размещаем заголовки остальных колонок Таблицы:

В клетке A22  -  “Интервалы”                       (границы интервалов)

В клетке C22 -  “ xo “                                        (центры интервалов)

В клетке D22 – “ m “                                   (наблюдаемые частоты)

В клетке E22 –“ Z “  (нормированные отклонения xo от среднего)           

В клетке F22 – “N*Ф(Z)”        (расчетные накопленные частоты)

В клетке G22 – “ kn“  (расчетные частоты норм.  распределения)

В клетке H22 – “Критерий”      (слагаемые критерия согласия для

                                                                  Нормального распределения)

В клетке I22 – “ku”      (расчетные частоты равномерного распр.)

В клетке J22 – “Критерий”      (слагаемые критерия согласия для

                                                                Равномерного распределения)                

8. В строке 23 вводим формулы

             A        B       C        D                     E

   23  =A4   =B4   =C4   =D4   =(B23-$F$18)/КОРЕНЬ($G$18)    .

                                  F                               G                       H         

   23  =$E$13*НОРМСТРАСП(E23)  =F23   =(D23-G23)^2/G23   

                                  I                                                        

   23  =ЕСЛИ(B23>$J$21; 0 ;$E$13*$I$2/($J$21-$I$21))        

                                  J

  23   =ЕСЛИ(I23 <> 0; (D23-I23)^2/I23; 0)

9.  Во  всех  столбцах  кроме G   копируем формулы из строки 23 в  

   следующие девять строк (строки 24-32).

                                                                                           G

  В клетку    G24  вводим формулу                 24   =F24-F23        .    

  и копируем ее в строки 25-32.

  1.   В клетках 33-й строки вводим  подзаголовки и формулы суммы:

                    A                                             D

     33  Число наблюдений:         =СУММ(D23:D32)  

               E                                            H                                J

33  Наблюдаемые значения  =СУММ(H23:H32)  =СУММ(J23:J32)

  1.   В клетки A34 и A35  вводим заголовки:  “Уровень значимости” и “Число интервалов”. В клетку D34 вводим формулу ( число интервалов L-3 )           

                                                   D

                                    34    =$H$21-3

а в клетку  D35 -  число    0,05

12. В клетку E35  вводим строку “Критическая точка”, а в клетку  H35 – формулу её вычисления

                                                   H

                          35     =ХИ2ОБР(D34;D35)            .

13. Для автоматического вывода заключения о характере распределения в  клетках  A37 и A38  вводим строки:

       “ГИПОТЕЗА  О  РАВНОМЕРНОМ РАСПРЕДЕЛЕНИИ”  и

       “ГИПОТЕЗА  О  НОРМАЛЬНОМ    РАСПРЕДЕЛЕНИИ”

в клетках H37 и H38 – формулы сравнения:

                                                    H

  1.  =ЕСЛИ(J33>H34;”ОТВЕРГАЕТСЯ” ; “ПРИНИМАЕТСЯ”)

                                                    H

38    =ЕСЛИ(H33>H34;”ОТВЕРГАЕТСЯ”; “ПРИНИМАЕТСЯ”)

14. Вводим для клеток соответствующие рамки, регулируем ширину столбцов, формат выводимых значений (выравнивание вправо/влево/по центру, число знаков после запятой).  Клетки H21 и D34, предназначенные для ввода исходных данных (числа интервалов и уровня значимости) закрашиваем каким-нибудь светлым тоном)

  1.  Ниже располагаем совместный график наблюдаемых  и расчётных  частот.

Построение графиков.

Для построения диаграммы  поставим курсор  в клетку A40 и в меню “Вставка” выберем пункт “Диаграмма” . В меню “Тип” выбираем “Гистограмма”  и нажимаем экранную кнопку

                                           “   Далее >  “

Выделяем столбец в столбце D заполненные клетки. В поле “Значение ”   должна появиться формула :

              =Лист1!D21:D28                   ( [Enter] не нажимать! )

Нажимаем экранную кнопку           “  Далее >   ”.

В окне свойств диаграммы  в поле “Название диаграммы” вводим

              Гистограмма и расчётные кривые

Нажав кнопку           Оси   ,  убираем  ось Y      (метку      ).

Нажав кнопку          Легенда  , убираем метки с диаграммы.

Нажав кнопку          Линии сетки  , убираем сетку.

Нажимаем экранную кнопку         Далее >     и помещаем диаграмму на имеющемся листе.

Нажимаем кнопку    Готово   .

Щёлкнув кнопкой мыши в поле диаграммы,  перемещаем диаграмму,  сдвигая её границы.  Щёлкнув дважды,  убираем рамку (тип “Невидимая”) и устанавливаем белый цвет фона.

Если диаграмма выделена, в верхней линейке меню имеется пункт “Диаграмма”. В этом меню выбираем пункт “Добавить данные…”.  Выделяем столбец G расчётных нормальных частот и нажимаем экранную кнопку  OK   .

Новые данные отображаются также в виде столбиковой диаграммы. Чтобы изменить тип диаграммы, поместим курсор мыши на столбец этой диаграммы и ДВАЖДЫ щёлкнем ПРАВОЙ кнопкой мыши. В меню “Тип диаграммы” выбираем “Точечная” и справа отмечаем ТРЕТИЙ рисунок ”Точечная диаграмма со сглаживающими линиями без маркеров”.

Аналогично добавляем на диаграмму данные из столбца I (расчетные частоты равномерного распределения).


1. Душа парила ввысь и там звезду нашл
2. НА ТЕМУ ldquo;Проблемы привлечения иностранных инвестиций в Россиюrdquo;
3. Марковский Жуйковой О
4. тема эндокринных желез представлена периферическими железами щитовидная паращитовидная яичники тестик
5. Иудейский культ
6. 20th century poetry hs sometimes been more generlly lbelled s fundmentl cretive ct using lnguge
7. а.. В чистом виде представляют собой представляют собой кристаллические вещества белого цвета хорошо раств
8. Лабораторная работа 2 Тема Жесткий диск
9. Об адресной социальной поддержке населения в Республике Татарстан
10.  Акционерное общество в РФ как организационноправовая форма среднего и крупного бизнеса Акционерные об
11. Тема 1- Понятие экологического права.html
12. Вечеров а также некоторые повести из Миргорода Ресниц и Арабески Портрет удельный вес фанта
13. ЗАДАНИЕ 1 ВАРИАНТ 3
14. Частные деньги проблемы и перспективы развития
15. темах Рассмотрено Утверждаю на заседании кафедры Зам
16. ВАРИАНТ 1620 16 Что такое банковская статистика отрасль социальноэкономической статистики зад
17. Герой нашего времени Во всякой книге предисловие есть первая и вместе с тем последняя вещь; о
18. темами Глава 1
19. Механика молекулярная физика и термодинамика
20. Интернет и телефон.html